[radvd-devel-l] losing default route

Pekka Savola pekkas at netcore.fi
Fri Jul 22 18:24:52 EDT 2005

On Fri, 22 Jul 2005, Tomasz Grobelny wrote:
> --- and this is repeated as before: ---
> [Jul 22 23:01:21] radvd: timer_handler called for eth2
> [Jul 22 23:01:21] radvd: sending RA on eth2
> [Jul 22 23:01:21] radvd: setting timer: 7.58 secs
> [Jul 22 23:01:21] radvd: calling alarm: 7 secs, 580494 usecs
> [Jul 22 23:01:21] radvd: calling alarm: 7 secs, 580282 usecs
> [Jul 22 23:01:21] radvd: recvmsg len=56
> [Jul 22 23:01:21] radvd: if_index 5
> [Jul 22 23:01:21] radvd: found Interface: eth2
> --- and once again it all stops after: ---
> [Jul 22 23:02:25] radvd: calling alarm: 0 secs, 302 usecs
> --- end of file ---

So, there is _nothing_ after that in the logs?  What are the about 10 
preceding messages prior to the last one?

Could you also run debugging with -d 5 so we could see which context 
set_timer is called.

Have you tried whether this worked in 0.7.2? (There were some changes 
in timestamp usage in 0.7.3)

If I'd have to guess, I'd say this is caused by a host sending an 
ill-timed RS just when radvd has sent out a RA, and it messes up the 
timing somehow.  If you want to try look at this, you could try adding 
a bit of debugging printing in the middle 'else 
if' of process.c:process_rs().. you could also try uncommenting the 
clear_timer line there.

Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

More information about the radvd-devel-l mailing list