[radvd-devel-l] Radvd problem with MIPv6 CN

Pekka Savola pekkas at netcore.fi
Mon Feb 11 06:40:40 EST 2008

On Mon, 11 Feb 2008, k k wrote:
> I'm currently experiencing some problems with running radvd together 
> with MIPv6. (NOTE: I'm running radvd and MIPv6 on my MN and CN as 
> well). My network works fine when there's a Correspondent Node (CN) 
> in the foreign network. However, when I ran radvd together with 
> MIPv6 without the CN, there were major ping problems(refer to 
> below).
> As mentioned earlier, MIPv6 and radvd worked out fine when the CN 
> was running. Next I tested MIPv6 and radvd without the CN and it 
> gave me ping fluctuation problems as shown:
> With radvd on MN:
> [root at localhost ~]# ping6 2001:106:1100:0:21c:f0ff:fe8f:2adc
> PING 2001:106:1100:0:21c:f0ff:fe8f:2adc(2001:106:1100:0:21c:f0ff:fe8f:2adc) 56 data bytes
> From 2001:106:2700:0:211:95ff:feca:5855 icmp_seq=0 Destination unreachable: Address unreachable
> 64 bytes from 2001:106:1100:0:21c:f0ff:fe8f:2adc: icmp_seq=1 ttl=62 time=1.08 ms
> When I executed a ?killall radvd?, the ping was stable again. Upon 
> activating radvd again, the ping went unstable. Has anyone had this 
> problem before or can someone help me out?

You don't describe why you want to run radvd on the MN.  Are you 
trying to do some NEMO experiments?

You're pinging CN's address from the MN., but are sometimes getting 
ICMP "address unreachable" errors from the MN's home address.

In other words, the "localhost" in question cannot perform address 
resolution for the CN address.

My suspicion is that when you try to run radvd on the MN, you have two 
default routes on the MN, or you have strange interface configuration 
on the MN, which prevents address resolution from working properly.

To find out more about this, I suggest you run radvd on MN with 
debugging enabled (e.g. with '-d 5 -m stderr' toggles), get '/sbin/ip 
-6 a l' printing before you start radvd, and compare it to '/sbin/ip 
-6 a l' listing when the problem is active.  Similar steps should be 
sone with '/sbin/ip -6 r l'.  You may also want to run 'tcpdump -n 
-vvv -s0 -i any icmp6' to capture ICMPv6 traffic on the MN.

Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

More information about the radvd-devel-l mailing list